Funding Delay 3/12/25

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 13:11 PDT

Identified

A funding delay has been identified affecting a subset of merchant accounts today, March 12th, 2025. Our team is actively working to resolve the issue, and we expect impacted merchants to receive their deposits within one business day (March 13th, 2025). Rest assured, we are addressing the situation with urgency. We apologize for the inconvenience.
Posted Mar 12, 2025 - 05:40 PDT
This incident affected: Merchant Funding.