Shift4 Payments Logo

Shift4 Chat Support is Degraded

Incident Report for Shift4

Resolved

This incident has been resolved and chat support is working as intended. Thank you for your patience.
Posted Jul 02, 2025 - 16:34 PDT

Identified

Shift4 is aware of an issue affecting our chat support systems. We are working to resolve this issue as quickly as possible. We sincerely apologize for the inconvenience.
Posted Jul 02, 2025 - 15:23 PDT
This incident affected: Third-Party Payments Provider or Vendor (Other).