Shift4 Phone Support is Degraded
Incident Report for Shift4
Resolved
This issue has been resolved.
Posted Dec 03, 2024 - 07:43 PST
Update
We are aware of an issue with our phone system due to our third party provider and are engaged in a resolution. In the interim, you may call us using our local phone # 484-838-6569 or utilize https://www.shift4.com/support to contact us via chat or form.
Posted Dec 03, 2024 - 07:17 PST
Identified
Shift4 is aware of an issue affecting our phone systems. We are working to resolve this issue as quickly as possible. We sincerely apologize for the inconvenience.
Posted Dec 03, 2024 - 07:02 PST
This incident affected: Third-Party Payments Provider or Vendor (Other).