Las Vegas Office Power Out & MyPortal/Citadel legacy site unavailable
Incident Report for Shift4
Resolved
This incident has been resolved.
Posted Aug 14, 2024 - 19:18 PDT
Investigating
The LV office is without power and the myportal legacy site is unavailable. Our technical teams are engaged and striving to restore power shortly.
Posted Aug 14, 2024 - 05:21 PDT
This incident affected: Third-Party Payments Provider or Vendor (Other).