Shift4 Payments Logo

Partial Funding Delay - April 30th Batches

Incident Report for Shift4

Resolved

This incident has been resolved and no further delays are occurring.
Posted May 02, 2025 - 06:50 PDT

Identified

Shift 4 is aware that a portion of batches from April 30th have been delayed by 1 business day for some of our US merchants. Deposits are expected to settle no later than tomorrow morning. We sincerely apologize for any inconvenience this may have caused and appreciate your understanding.
Posted May 01, 2025 - 04:50 PDT
This incident affected: Merchant Funding.