Shift4 Payments Logo

Funding Delay Up to 24 Hours - Federal Reserve

Incident Report for Shift4

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 13:18 PDT

Identified

Shift4 has been notified that some of our merchants' deposits scheduled for today may be delayed from the Federal Reserve. Deposits are expected between later today (August 4th) and early tomorrow (August 5th). Thank you for your patience and understanding and we sincerely apologize for the inconvenience.
Posted Aug 04, 2025 - 05:20 PDT
This incident affected: Merchant Funding (Merchant Funding USA).